Google Play Integration Failing
Incident Report for AppTweak
Resolved
The integration system has been updated to work with more account types
Posted about 1 month ago. Dec 12, 2017 - 23:21 UTC
Identified
Several users have notified us of trouble while trying to integrate their Google Play Developer console data on AppTweak. This feature is in beta and we have been able to identify some use case which are not covered by our current implementation.

We have temporary disabled this feature while we fix our integration system. Users who have successfully integrated their credentials are not affected and will not loose access to their data.
Posted about 1 month ago. Dec 12, 2017 - 11:12 UTC